Selasa, 21 Juni 2011

Konfigurasi Router dengan menggunakan IP Statis

1. Memasang Peralatan seperti Gambar di Bawah Ini :


2. Memberi Nama Hostname pada Masing-masing Router :

Router>ena
Router#conf t
Router(config)#hostname R1

Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2

Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3


3. Memasukkan IP Address pada Masing-masing Interface :
R1(config)#int fa0/0
R1(config-if)#ip add 172.16.3.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int s0/0/0
R1(config-if)#ip add 172.16.2.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
R1(config-if)#exit

R2(config)#int fa0/0
R2(config-if)#ip add 172.16.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int s0/0/0
R2(config-if)#ip add 172.16.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int s0/0/1
R2(config-if)#ip add 192.168.1.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut
R2(config-if)#exit

R3(config)#int fa0/0
R3 (config-if)#ip add 192.168.2.1 255.255.255.0
R3 (config-if)#no shut
R3 (config-if)#exit
R3 (config)#int s0/0/1
R3 (config-if)#ip add 192.168.1.1 255.255.255.0
R3 (config-if)#no shut

4. Mengenalkan Masing-masing Jaringan dengan Menggunakan Router Statis :
R1(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.2
R1(config)#ip route 192.168.0.0 255.255.252.0 172.16.2.2
R1(config)#end

R2(config)#ip route 172.16.3.0 255.255.255.0 172.16.2.1
R2(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
R2(config)#end

R3 (config)#ip route 172.16.0.0 255.255.252.0 192.168.1.2
R3 (config)#end

5. Memasukkan IP Address pada Masing-masing PC :
PC1


PC2

PC3


6. Memeriksa Koneksi dengan Perintah ping pada Masing-masing PC :
PC1

Lakukan hal yang sama pada PC2 dan PC3

7. Memeriksa Koneksi dengan Perintah traceroute :
R1#traceroute 192.168.1.0
Type escape sequence to abort.
Tracing the route to 192.168.1.0

1 172.16.2.2 2 msec 5 msec 7 msec 
R1#traceroute 192.168.2.0
Type escape sequence to abort.
Tracing the route to 192.168.2.0

1 172.16.2.2 7 msec 7 msec 5 msec 
2 192.168.1.1 9 msec 8 msec 10 msec 
R1#traceroute 172.16.2.0
Type escape sequence to abort.
Tracing the route to 172.16.2.0

1 172.16.2.2 3 msec 5 msec 5 msec 
R1#traceroute 172.16.1.0
Type escape sequence to abort.
Tracing the route to 172.16.1.0

1 172.16.2.2 7 msec 6 msec 2 msec 

R2#traceroute 172.16.3.0
Type escape sequence to abort.
Tracing the route to 172.16.3.0

1 172.16.2.1 6 msec 4 msec 8 msec 
R2#traceroute 192.168.2.0
Type escape sequence to abort.
Tracing the route to 192.168.2.0

1 192.168.1.1 4 msec 5 msec 6 msec 

R3#traceroute 172.16.1.0
Type escape sequence to abort.
Tracing the route to 172.16.1.0

1 192.168.1.2 8 msec 4 msec 6 msec 
R3#traceroute 172.16.2.0
Type escape sequence to abort.
Tracing the route to 172.16.2.0

1 192.168.1.2 4 msec 4 msec 5 msec 
R3#traceroute 172.16.3.0
Type escape sequence to abort.
Tracing the route to 172.16.3.0

1 192.168.1.2 8 msec 8 msec 5 msec 
2 172.16.2.1 11 msec 10 msec 13 msec 


8. Memeriksa Koneksi dengan Menggunakan Perintah show ip route :
R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets
S 172.16.1.0 [1/0] via 172.16.2.2
C 172.16.2.0 is directly connected, Serial0/0/0
C 172.16.3.0 is directly connected, FastEthernet0/0
S 192.168.0.0/22 [1/0] via 172.16.2.2


R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
C 172.16.2.0 is directly connected, Serial0/0/0
S 172.16.3.0 [1/0] via 172.16.2.1
C 192.168.1.0/24 is directly connected, Serial0/0/1
S 192.168.2.0/24 [1/0] via 192.168.1.1


R3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/22 is subnetted, 1 subnets
S 172.16.0.0 [1/0] via 192.168.1.2
C 192.168.1.0/24 is directly connected, Serial0/0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0

9. Memeriksa Koneksi dengan Menggunakan Perintah show ip interface brief :
 
R1#sh ip int br
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.16.3.1 YES manual up up

FastEthernet0/1 unassigned YES manual administratively down down

Serial0/0/0 172.16.2.1 YES manual up up

Serial0/0/1 unassigned YES manual administratively down down

Vlan1 unassigned YES manual administratively down down


R2#sh ip int br
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.16.1.1 YES manual up up

FastEthernet0/1 unassigned YES manual administratively down down

Serial0/0/0 172.16.2.2 YES manual up up

Serial0/0/1 192.168.1.2 YES manual up up

Vlan1 unassigned YES manual administratively down down


R3#sh ip int br
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.2.1 YES manual up up

FastEthernet0/1 unassigned YES manual administratively down down

Serial0/0/0 unassigned YES manual administratively down down

Serial0/0/1 192.168.1.1 YES manual up up

Vlan1 unassigned YES manual administratively down down


10. Memeriksa Koneksi dengan Menggunakan Perintah show cdp neighbors detail :
R1#sh cdp neighbors detail
Device ID: Switch
Entry address(es): 
Platform: cisco 2960, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/1
Holdtime: 171

Version :
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team

advertisement version: 2
Duplex: full
---------------------------

Device ID: R2
Entry address(es): 
IP address : 172.16.2.2
Platform: cisco C1841, Capabilities: Router
Interface: Serial0/0/0, Port ID (outgoing port): Serial0/0/0
Holdtime: 152

Version :
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team

advertisement version: 2
Duplex: full


R2#sh cdp neighbors detail

Device ID: Switch
Entry address(es): 
Platform: cisco 2960, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/1
Holdtime: 156

Version :
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team

advertisement version: 2
Duplex: full
---------------------------

Device ID: R1
Entry address(es): 
IP address : 172.16.2.1
Platform: cisco C1841, Capabilities: Router
Interface: Serial0/0/0, Port ID (outgoing port): Serial0/0/0
Holdtime: 179

Version :
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team

advertisement version: 2
Duplex: full
---------------------------

Device ID: R3
Entry address(es): 
IP address : 192.168.1.1
Platform: cisco C1841, Capabilities: Router
Interface: Serial0/0/1, Port ID (outgoing port): Serial0/0/1
Holdtime: 128

Version :
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team

advertisement version: 2
Duplex: full


R3#sh cdp neighbors detail

Device ID: Switch
Entry address(es): 
Platform: cisco 2960, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/1
Holdtime: 148

Version :
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team

Senin, 06 Juni 2011

Tugas Jarkom Praktek 3

Planning and Building an Enterprise Network
Objective
·         Plan, design, and build a large enterprise network utilizing multiple VLANs, inter-VLAN routing, and VTP domains.
Background / Preparation
A new remote site has been acquired by your company and the network needs to be built. You must plan, design, and build the network to meet company standards. The following equipment has been provided.
·         Three Cisco 2960 switches have been purchased, one for each of the three floors.
·         One Cisco 1841 router has been purchased as the Integrated Service Router (ISR).

Step 1: Connecting the network
Utilize the first FastEthernet interface on the ISR router to connect to the last FastEthernet interface on the Floor 1 switch.
Connect GigabitEthernet 1/1 on the Floor 1 switch to GigabitEthernet 1/1 on the Floor 2 switch.
Connect GigabitEthernet 1/2 on the Floor 2 switch to GigabitEthernet 1/1 on the Floor 3 switch.

Step 2: Configure basic switch and router configurations
Utilize the following table to configure the ISR router, Floor 1, Floor 2, and Floor 3 switches.
Router
Router>en
Router>enable
Router#conf
Router#configure t
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hos
Router(config)#hostname ISR_Rtr
ISR_Rtr(config)#en
ISR_Rtr(config)#ena
ISR_Rtr(config)#enable pas
ISR_Rtr(config)#enable password cisco123
ISR_Rtr(config)#li
ISR_Rtr(config)#line vt
ISR_Rtr(config)#line vty 0 4
ISR_Rtr(config-line)#pas
ISR_Rtr(config-line)#password class
ISR_Rtr(config-line)#login
ISR_Rtr(config-line)#exit
ISR_Rtr(config)#lin
ISR_Rtr(config)#line co
ISR_Rtr(config)#line console 0
ISR_Rtr(config-line)#pas
ISR_Rtr(config-line)#password class
ISR_Rtr(config-line)#login
ISR_Rtr(config-line)#exit
ISR_Rtr(config)#
Switch set the all switches
Switch>ena
Switch>enable
Switch#con
Switch#conf
Switch#configure t
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#host
Switch(config)#hostname Floor1_Sw
Floor1_Sw(config)#ena
Floor1_Sw(config)#enable pas
Floor1_Sw(config)#enable password cisco123
Floor1_Sw(config)#li
Floor1_Sw(config)#line vt
Floor1_Sw(config)#line vty 0 4
Floor1_Sw(config-line)#pas
Floor1_Sw(config-line)#password class
Floor1_Sw(config-line)#login
Floor1_Sw(config-line)#exit
Floor1_Sw(config)#lin
Floor1_Sw(config)#line con
Floor1_Sw(config)#line console 0
Floor1_Sw(config-line)#pas
Floor1_Sw(config-line)#password class
Floor1_Sw(config-line)#login
Floor1_Sw(config-line)#exit
Floor1_Sw(config)#
Do same to switch 2 and switch 3.
Step 3: Configure the interfaces connecting the router and switches
  1. Set the interfaces connecting the Floor 1, Floor 2, and Floor 3 switches as trunk ports.
  2. Set the interface on the Floor 1 switch connecting to the ISR router as a trunk port.
  3. Enable the interface on the ISR router connecting to the Floor 1 switch.
  4. Create and configure three sub-interfaces on the ISR routers FastEthernet 0/0 interface. Use the following table.
1.       Set the encapsulation for each sub-interface.
2.       Set the IP address for each sub-interface.
a.        Floor1_Sw(config)#interface gigabitEthernet 1/1
Floor1_Sw(config-if)#sw
Floor1_Sw(config-if)#switchport mo
Floor1_Sw(config-if)#switchport mode tr
Floor1_Sw(config-if)#switchport mode trunk
Do same to switch 2 and switch 3.
b.      Floor1_Sw(config)#interface fastEthernet 0/24
Floor1_Sw(config-if)#sw
Floor1_Sw(config-if)#switchport mo
Floor1_Sw(config-if)#switchport mode tr
Floor1_Sw(config-if)#switchport mode trunk
c.       ISR_Rtr(config)#int
ISR_Rtr(config)#interface f
ISR_Rtr(config)#interface fastEthernet 0/0
ISR_Rtr(config-if)#no ip add
ISR_Rtr(config-if)#no ip address
ISR_Rtr(config-if)#no sh
ISR_Rtr(config-if)#no shutdown
ISR_Rtr(config-subif)#exit
ISR_Rtr(config)#
d.      ISR_Rtr(config)#int
ISR_Rtr(config)#interface f
ISR_Rtr(config)#interface fastEthernet 0/0.20
1.       ISR_Rtr(config-subif)#en
ISR_Rtr(config-subif)#encapsulation dot1q 20
2.       ISR_Rtr(config-subif)#ip ad
ISR_Rtr(config-subif)#ip address 192.168.20.1 255.255.255.0
ISR_Rtr(config-subif)#exit
Step 4: Configure a VTP Domain
Utilize the following table to configure the Floor 1, Floor 2, and Floor 3 switches.
a.       Floor 2 dan 3
1.       Floor2_Sw(config)#vt
Floor2_Sw(config)#vtp do
Floor2_Sw(config)#vtp domain SiteX
Changing VTP domain name from NULL to SiteX
2.       Floor2_Sw(config)#vt
Floor2_Sw(config)#vtp mo
Floor2_Sw(config)#vtp mode cl
Floor2_Sw(config)#vtp mode client
Setting device to VTP CLIENT mode.
3.       Floor2_Sw(config)#vt
Floor2_Sw(config)#vtp pas
Floor2_Sw(config)#vtp password ciscoVTP
Setting device VLAN database password to ciscoVTP
Floor2_Sw(config)#exit
b.      Floor 1
1.       Floor1_Sw(config)#vt
Floor1_Sw(config)#vtp do
Floor1_Sw(config)#vtp domain SiteX
Domain name already set to SiteX.
2.       Floor1_Sw(config)#vt
Floor1_Sw(config)#vtp mo
Floor1_Sw(config)#vtp mode se
Floor1_Sw(config)#vtp mode server
Device mode already VTP SERVER.
3.       Floor1_Sw(config)#vt
Floor1_Sw(config)#vtp pa
Floor1_Sw(config)#vtp password ciscoVTP
Setting device VLAN database password to ciscoVTP
Floor1_Sw(config)#exit
Step 5: Configure VLANs
Utilize the following table to configure the VLANs from the VTP server.
        Floor1_Sw(config)#vl
Floor1_Sw(config)#vlan 20
Floor1_Sw(config-vlan)#na
Floor1_Sw(config-vlan)#name Admin
Floor1_Sw(config-vlan)#exit
Floor1_Sw(config)#vl
Floor1_Sw(config)#vlan 25
Floor1_Sw(config-vlan)#na
Floor1_Sw(config-vlan)#name Management
Floor1_Sw(config-vlan)#exit
Floor1_Sw(config)#vl
Floor1_Sw(config)#vlan 30
Floor1_Sw(config-vlan)#na
Floor1_Sw(config-vlan)#name Finance
Floor1_Sw(config-vlan)#exit
Floor1_Sw(config)#
Step 6: Add switch ports to the appropriate VLAN
  1. Configure the Floor 1 switch so that FastEthernet 0/1 is on VLAN 20.
  2. Configure the Floor 2 switch so that FastEthernet 0/1 is on VLAN 25.
  3. Configure the Floor 3 switch so that FastEthernet 0/1 is on VLAN 30.
a.       Floor1_Sw(config)#int
Floor1_Sw(config)#interface f
Floor1_Sw(config)#interface fastEthernet 0/1
Floor1_Sw(config-if)#sw
Floor1_Sw(config-if)#switchport mo
Floor1_Sw(config-if)#switchport mode ac
Floor1_Sw(config-if)#switchport mode access
Floor1_Sw(config-if)#sw
Floor1_Sw(config-if)#switchport ac
Floor1_Sw(config-if)#switchport access v
Floor1_Sw(config-if)#switchport access vlan 20
Floor1_Sw(config-if)#exit
Floor1_Sw(config)#
b.      Floor2_Sw(config)#int
Floor2_Sw(config)#interface f
Floor2_Sw(config)#interface fastEthernet 0/1
Floor2_Sw(config-if)#sw
Floor2_Sw(config-if)#switchport mo
Floor2_Sw(config-if)#switchport mode ac
Floor2_Sw(config-if)#switchport mode access
Floor2_Sw(config-if)#sw
Floor2_Sw(config-if)#switchport ac
Floor2_Sw(config-if)#switchport access v
Floor2_Sw(config-if)#switchport access vlan 25
Floor2_Sw(config-if)#exit
Floor2_Sw(config)#
c.       Floor3_Sw(config)#int
Floor3_Sw(config)#interface f
Floor3_Sw(config)#interface fastEthernet 0/1
Floor3_Sw(config-if)#sw
Floor3_Sw(config-if)#switchport mo
Floor3_Sw(config-if)#switchport mode ac
Floor3_Sw(config-if)#switchport mode access
Floor3_Sw(config-if)#sw
Floor3_Sw(config-if)#switchport ac
Floor3_Sw(config-if)#switchport access v
Floor3_Sw(config-if)#switchport access vlan 30
Floor3_Sw(config-if)#exit
Floor3_Sw(config)#
Step 7: Connect and configure client workstations
  1. Connect PC0 to the Floor 1 switch via FastEthernet 0/1.
  2. Connect PC1 to the Floor 2 switch via FastEthernet 0/1.
  3. Connect PC2 to the Floor 3 switch via FastEthernet 0/1.

Step 8: Verify connectivity
  1. Using the Command Prompt, ping PC1 and PC2 from PC0.
  2. Using the Command Prompt, ping PC0 and PC2 from PC1.
  3. Using the Command Prompt, ping PC0 and PC1 from PC2.
  4. Your completion percentage should be 100%. If not, click Check Results to see which required components are not yet completed.